Jump to content

Recommended Posts

Hello Lads (and a few Lasses),


I received my new Saitek X52 Pro HOTAS unit yesterday. It is a vast improvement over the Logitech unit I have been using (especially since the Logitech is pretty worn out).


I've been looking over the, almost non-existent, information that came with the thing. Before I get involved in a few days work trying to program it, I thought it wise to ask here, first, for any words of wisdom. Or, just in case someone at MH has gone through this routine and has a file they're willing to share.


I can use it by programming the default FSX "Controls" and .cfg file, but that just touches the surface of what the X52 is supposed to do. Example: the throttle has a detent at the top and bottom of its travel that might be intended for "Reverse Thrust" (F2) at the bottom and maybe "Afterburner" (??) at the top. This is not something you can program in the FSX software. I also have the paid version of FSUIPC which might be another approach to take, although one I am not familiar with. 


There is a file, for instance, on the Saitek website that is (supposedly) a profile for FSX. Typically, the software available on the manufacturers website does not work with the unit they ship you - I'll have a good old rant on that subject some other time. The one I have uses profile files with the suffix [.dat] and the profile on the website has a [.pr0] suffix. I tried the obvious - renaming the .pr0 file to .dat but that just generated a pop-up warning telling me that the file didn't contain a profile. Rats!


Next, I'm going fishing on various sites like Avsim and FS, etc.


If anyone can help, I'd appreciate it.


Link to post
Share on other sites

I think the FSUIPC paid version might be a good way to go. I haven't used it but I understand that it allows you to set up custom control profiles for individual aircraft in your FSX installation and automatically loads the correct profile when you select the associated aircraft.


I don't know how well it works and have zero first-hand experience with it, so take it with a grain of salt, but if it does work as advertised, sounds like a good way to go.


Good luck!


Link to post
Share on other sites

To get full functionality from a HOTAS it's best to program it, at least for FS. Can't help you with the saitek setup though, as I use a cougar, but usually there's a gui that should make things a bit simpler. All you'll need to hand will be a list of the key commands for FSX.

To use the detents accurately you'll probably need some kind of throttlerange statement in the profile, but I don't know how to do that for saitek controllers, so I can't help,sorry.

Link to post
Share on other sites

Hi John!    ^_^


FWIW, I adopt a standard procedure for all HOTAS units (I am currently using the Warthog):


1. Uninstall all of the maker's "programming" software, leaving only the driver. (Check that Windows can still "see" the device(s)).


2. Assign and calibrate all the axes with FSUIPC.


3. Program all the buttons and switches with LINDA.


It works for me.... (Although you may be surprised to discover how long it takes you to implement everything precisely to your liking).   ;)


Be aware, however, that occasionally you may encounter non-standard controls such as the 3-way mode control on the X52: these aren't supported other than (in that case) by the Saitek software. However, LINDA offers an intelligent Shift facility (Global or Local) that helps to compensate.    :)






Link to post
Share on other sites
Thanks for ringing in on this one Brian,


It's giving me kittens!


I'm going to be in real trouble if I try to get this thing running before GAAR. I think I'll give it a pass and go out and buy a new Logitech Extreme 3D Pro (what I've been using for the past couple years). They're relatively cheap.


I seem to have a driver disagreement. 


I loaded the X52 Pro from the factory disk and it seemed to work fine, except for the mapping. The factory disk was, of course, five years behind, so I couldn't use the mapping software. It kept writing files with the .dat suffix and trying to read .pr0 files.


I went digital dumpster diving and came up with a new set of drivers and new mapping software from the Saitek site, so I off loaded the stuff from the disk and re-loaded the newer drivers and programming software (X52 Pro, Win7) from Saitek.


All this resulted in was the loss of the MFD and no real improvement, except that the programming software now saves files in the .pr0 format and the joystick seems to recognize them. Not that it matters, because strange thing happen. I think I have a clue as to what is wrong with the MFD - the stick mapping that shows up in Win7 when you load it from "Devices and Printers" looks like this:




The button assignments are the key. The MFD has two rollers with buttons attached. By this, I mean that you can "roll" through menu choices, then press on the roller to select. Similar to the roller/button on a mouse. The two roller/button assignments are "19" and "39" (the middle one, "32" is also a button/roller switch but it is elsewhere on the throttle handle). More on this shortly, see below:


All seems to be sweetness and light until I load FSX and go looking for the "Calibration" diagram in there. Here's what that one looks like:




Note that the button assignments end at 32. Effectively removing the "39" button/roller from the equation as far as FSX is concerned.


This morning I offloaded the whole shooting match, then reloaded the drivers ONLY.


Now I'm at the point where I can take your advice.


I do have the paid version of FSUIPC but have never used anything beyond saving incremental flight files to recover from problems when flying in Air Hauler.


I'll go looking for the LINDA software. I remember having a look a while back and shuddering.


I really want a better joystick and separate throttle set-up - I'm willing to go the distance and get involved with FSUIPC and Linda (don't tell my wife).


Crying shame you have to leap through these hoops after forking over hard-earned dollars for a piece of hardware that is expected to work right out of the box.

Link to post
Share on other sites

Hi John!


I feel for you, my friend — it is frustrating indeed.    :(


The only crumbs of comfort I can offer you are these:


a) Don't be overly concerned if the Windows representation of the device doesn't exactly match up to the device itself. Windows does its best, but that's all....


b) You will be able to see better how things really respond when you start using FSUIPC and LINDA. They both automatically display which axis (FSUIPC) or button (LINDA) you are using/assigning/calibrating, so you can see not only that they are responding (and to what extent), but also what device number / channel number / whatever they correspond to.


But this is inevitably going to be a longer process if you also need to get to grips with FSUIPC and LINDA along the way.  :mellow:


I would strongly recommend that before doing anything else you spend some time working out what buttons and axes you want to assign to which functions in the aircraft concerned — don't forget to include a few for essential EZCA views, if you use EZCA or something similar. Document this, and then gradually work your way through them, ticking them off as you go. Happily, with a HOTAS there is usually no shortage of buttons and axes to assign.    :P


For example, here's part of my documentation of the controls and views that I use with the Warthog (for the NGX, in this case):—




But you don't have to implement everything at the very beginning, of course. As long as you have planned which controls you will be using for what, you will be spared the irritating hassle of changing things (and then unlearning the previous assignments as you fly). So concentrate on getting the axes right first of all, then add the essentials (gear, flaps etc) and gradually fill in the rest of the stuff as you go along. That way you get to test everything as you go, and end up with a fully functional and practical set of controls that are matched to your requirements.


Then you do it all over again for the next aircraft, whilst keeping intact as much as possible of the standard control set you have already established.  ;)


I suggest that you go here — http://forum.avsim.net/topic/376920-linda-beginners-guide-a-very-detailed-manual/#entry2394616 — and download the extended manual I wrote for LINDA. Since I wrote it, as well as information about installing and configuring LINDA it also contains all sorts of associated side-issues, including an explanation of how LINDA came to be and how it works alongside FSUIPC, what an HID is, an example of assigning a three-way switch to the gear (with central depressurised position), and so on.


As for FSUIPC, you will find that it comes with a ton of documents (installed below the 'Modules' folder in your fsx setup). The most important document to read is the FSUIPC4 User Guide, closely followed by FSUIPC4 for Advanced Users (you count as an Advanced User if you actually read the User Guide). In those documents you will discover some of the amazing things that the paid version of FSUIPC can do for you: it always astounds me how many people have it, but have little idea of its capabilities. Be sure that you install the very latest version of FSUIPC, however (currently v4.928), and keep it up to date. 


Good luck with all that! If you are starting with no previous knowledge at all of FSUIPC and LINDA you are going to need to do quite a lot of reading and experimenting as you go. But your reward will be a set of aircraft controls that are tailored precisely to how you fly and the kit that you have, so it's well worth it.    :D


Don't forget to let us know how you're doing — and to yell if you get stuck at any point.


All the best,




Link to post
Share on other sites

my goodness looking at all that has put me right off replacing my steam driven joystick with a hotass. By the time I had gone through setting up all those parameters I would have forgotten what half of the do. :)

Link to post
Share on other sites

Thanks for your reply, Brian,


I downloaded Linda last night and started through the learning process. I'm being introduced to file locations that I never thought I'd be seeing from the inside. 


FSUIPC, I have had for some time now, but have never really gotten into it. I guess that is going to change.


I ran into a glitch right off the bat: The Linda GUI does not re-size and there are a few things on the bottom of the page that I'll bet are important. I went looking on the Linda Forum, however, couldn't find any reference to this. here's a screenshot of what I see:




Note how the icon to the left of the "X" (top right) that normally would allow you to re-size the GUI is grayed out. No little re-sizing arrows appear at the corners, either. This isn't too bad because the icons across the bottom of the GUI can still be clicked. I've looked over a few of the other pages, though, and it appears important that I be able to see the full GUI as there's command-specific icons displayed here.


You might note from the screenshot that your tutorial is included in the "Modules" folder - thank you. Also, I guess I'd better see about finding and disabling (or getting rid of) the reference to the VRInsight MCP Panel. Don't I wish I had one of those, but sadly such is not the case. No idea where the reference comes from.


Bet you didn't think you'd be giving Win7 tutorials today. I went looking on the internet and, so far, have not been successful finding a solution. 

Link to post
Share on other sites

Hi John!


Have you been through the complete installation process for LINDA?


What is the resolution of your screen? (I can't get to my fsx machine at the moment, but it could well be that the LINDA GUI is sized at something like 800x600 and so can't be resized).


I still somehow have this feeling that you need to do some more, careful, reading......   ;)   For example, why are you starting with LINDA rather than getting your axes right in FSUIPC? And have you completely uninstalled the Saitek programming software?


Most importantly, have you completed a plan for all your control assignments?    :)





Ah, but as with so many things in this life, no pain = no gain.     :cool:







Link to post
Share on other sites
Hi Brian,


I'm (sort of) on track.


I thought I'd start out simple. I put the Saitek unit aside and hauled out the old faithful Logitech one. The Control Assignment map is, understandably, quite brief. Copy available if you'd like (It's a Word.doc file)


I downloaded Linda and did as requested, saved a copy of my "Modules" folder and inserted the unzipped Linda files into the Modules folder - that can be seen in the screenshot. To the best of my knowledge   ;)  the Saitek SOFTWARE has been removed or at least removed by wi7's add and remove programs thingie. I re-loaded the Saitek drivers, though.


Linda recognised the Joystick.


Re: The Linda GUI - My screen resolution is 1366 X 768. Went all the way down to 800 x 600 - much worse, couldn't see the sides or the bottom. 1024 X 768 seems to be the minimum I can set to and still see everything on the screen. Almost seems as though the Linda GUI needs something larger than 768, but I can't go that high on the screen Y-Axis. 1366 X 768 is my max. This one is still on the "unsolved" list.


I went and had a look at Linda because the tutorial (manual) suggested that should be my first move. I did the Installation on page 4. Then I removed all the FSUIPC joystick references in the fsuipc.ini file and went into the standard.xml file and removed all the joystick assignments (except the axis and mouse assignments).


I setup Linda and ticked the three boxes in the top half of the "Linda Settings", leaving the "Linda Advanced settings" for future consideration.


After that everything went to hell in a handbasket. FSUIPC (ver 4.9) doesn't seem to work for setting the axis. I was getting some strange things happening. Going into FSUIPC "Joystick Calibration" and following the instuctions on page 47 of the FSUIPC manual turned the elevators into all or nothing controls. Push slightly forward and the elevators go full travel down. Same with the opposite way - full up. I'm pretty sure I followed the instructions to the letter. I returned everything to normal by hitting the "Reload all Settings" button.


I went into the FSX Menu and set the axis controls using the stock controls menu. At least they work. There's something called "Axis Assignment" in the fsuipc menu tabs, but I've not touched that (it's all blank).


I started FSX, loaded the stock C172 and wrote the FSX Default in Linda. All went well and it flew faultlessly. In fact, I've never had the elevator trims working as close to the RW as they are now.


I'm still on the back side of the power curve on this stuff. I tried to make a "new" module in Linda and copy the FSX default over to one called C172. Linda made the file and the commands are all there, but every time I try to save it I get an error message. More study needed. I can reload it, so I can't figure out what Linda's problem is. 


Any idea where these modules are stored?


Tomorrow, I may take the plunge and try programming Linda for the X52 Pro. 


Thanks again, Brian

Link to post
Share on other sites

Hi John!


Apologies, but RW issues are causing me not to post here too often these days (the post-Christmas storms lifted a corner of my roof, and in the ingress of water has inter alia knocked out some of the electricity supply to the house, and life is tedious). I will briefly offer what little help I can under the circumstances.


I have now been able to check the LINDA screen. It is indeed not resizable, and seems to be 900 x 850 px, so you should have no difficulty whatsoever viewing it on your 1366x768 resolution screen (it is perfectly clear on mine at 5760x1200).


> "I went and had a look at Linda because the tutorial (manual) suggested that should be my first move."


Ah. Which manual would that be, I wonder? My advice regarding your first move was exactly the contrary. Perhaps if you are following a different manual you should let that be your guide, and I will bow out gracefully. It is not usually helpful to pursue two different approaches simultaneously.


"FSUIPC (ver 4.9) doesn't seem to work for setting the axis....."


Hmm, well since LINDA depends on FSUIPC, that was the reason why I recommended that you get your axes working in FSUIPC first (and after making your plan). But clearly you are not following that advice 


FWIW therefore, your symptoms might be consistent with not having calibrated the axes in Windows, so perhaps you might do that and then try again. You also need to be absolutely sure that the axes are not also assigned within FSX itself (but having read Pete Dowson's manual you will already be aware of that, of course).


> "I went into the FSX Menu and set the axis controls using the stock controls menu."


OK, so it appears that you have not read Pete's manual.  <sigh>


> "More study needed."


Yup, I reckon you've hit the nail squarely on the head.   :thum:


> "Any idea where these modules are stored?"


Yes, and it's explained both in the original LINDA manual and also in the extended version that I wrote. But the modules supplied with LINDA are perfectly capable of operating the stock aircraft without any sort of modification, so why you are attempting to make a new module is unclear: it sounds as though you haven't read (or haven't understood) the LINDA manuals. So I suspect that you are also using the word "module" in a different context to its normal usage in LINDA — certainly, the likelihood of you being able to write your own LINDA module is vanishingly small, so I'm at a loss to understand what you're trying to do.   :huh:  


Jumping randomly from one approach to another is not going to give you good results, I'm afraid. Either decide that you're going with standard assignments within FSX (accepting the limitations that brings) or else resign yourself to doing some serious reading and learning, planning your control layout, and implementing that plan in a systematic way (FSUIPC axes first). Or, of course, follow whatever manual told you to begin with LINDA.   :)


Best of luck,









Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...