Jump to content

Recommended Posts

Hi everyone!


I want to get back into FSX but the load times are ridiculous and SSDs are out of the question sadly (5mins to load to splash screen, another minute to open aircraft list). I simply have a bloated FSX - currently about 70Gb, mostly aircraft, and a lot of them I don't even like very much. I want to start over.

I have my FSX Acceleration Gold DVD with me, plus Traffic X, AirHauler, and some basic add-ons I got ages ago. I have REX Essential Plus Overdrive but no disc on me I believe (may have been a download).


Ideally, I'd uninstall completely, and remove EVERY add-on I've currently got, whilst keeping REX installed on the system. Then, I'd reinstall a clean FSX Acceleration and slowly add stuff back that I know I want. 


Sadly, I haven't got a clue what to do, and last time I tried I messed it all up somehow.


Could someone give me a simpletons guide?


I remember something about a bible for tweaking FSX somewhere, but again treat me like an idiot and walk me through please!


Hopefully if this goes well, I'll be up and raring to go for another epic ATWC sometime.


Cheers everyone!


Oh - and if anyone has some really good freeware suggestions I'm all ears! My specs are on the left :)

Link to post
Share on other sites

There shouldn't be a problem with your suggestion.


Normally, I'd remove all the addons first through their own uninstaller or the control panel, finally take off FSX. Make sure that you rename or delete the FSX folder containing the CFG or a reinstall will use it (like mine does-got to sort that!). Then remove the FSX folder that everything was in just to be sure. You should be able to leave REX and run it once FSX is back on, should be able to configure it to match the location of the new install if you change it, again this caused me no problems.


Start here for FSX CFG tweaks.




Hope this helps


Link to post
Share on other sites

You can open an aircraft config and on the the liveries you don't want, change the panel to = 0



This will remove the livery from loading.

You can also do it for entire aircraft by changing the panel folder name e.g. panel0 this will remove the plane entirely from loading.

If it takes a while to load at start why don't you try disable preload in the fsx config (Google it)

If loading the flight takes a long time you could try backing up the scenery config and then remove all addon entries from scenery library that you are not going to fly.

I have multiple scenery files for different areas I fly - one is just for uk for internal uk flights. Improves my loading times but some might say makes no difference. I think differently but each to their own :)

Ive improved my scenery blurring issues with Dx10 and the fixer - does not help load times of flights and splash screen load.

Good luck mate

Link to post
Share on other sites
  • 11 months later...

This is a year-old thread - however, it suits my purpose exactly and rather than bloat MH with another post, I'll add my tale of woe here.


Briefly: HDD crash last Friday. This always happens just before a long weekend. Rats! I could load the Bios, but that was it. All I got on the monitor was a black screen, no mouse, no joy. I took the computer apart, removed the mobo battery, the memory, the CPU, cleaned all the components (many dust bunnies living in the fans) then re-assembled. Yahoo! everything back to normal - that is, until I put the box to sleep that night. Next morning, Saturday, same thing: Bios but no way to boot. This time the patient did not respond to surgery and was declared DOA after a few hours of work.


My solution was to resurrect a 100Gb SSD that came off the boat and had never been used. I plugged that in, called it C: Drive in the Bios, then loaded Win7Pro from my original disk. 268 updates later, I had a working Win7 system back. The original, crashed, HDD, I called E: Drive and went for a stroll in its contents. Good news is that all software seems to be present - Bad news is that both P3d and FSX report missing .dll's and won't load. These dll's are supposed to be resident in the windows sub-directories.


Easy fix: search for the dll's in backups and load then to the appropriate directories - Not!


Win7, despite the fact that I'm logged in to the (hidden) Administrator account with Account Control turned off, refuses to let me copy to one of the windows sub-directories. So here I am back at square one without operational Sim software.


Next fix: Re-load FSX from the original CD's - Not!


Seems that if you leave CD's hanging around, unused, for long periods they get stupid. Long and short of it is that I was unable to "repair" my FSX install on the old drive. I had to do a complete new install to the E: drive (C: is only 100Gb, so is a poor candidate for an FSX install). The original disks were a bear to deal with. Many attempts later, I finally got Disk1 to run in the CD/DVD drive. Most attempts all I got was a lot of "chatter" or "stutter" sounds from the drive and no access to the software.


Anyone know where I can buy a new (don't even mention that pack of thieves on eBay) FSX Gold Disk set? I finally got the drive to read enough of the disk to put together a new install.


Fortunately, I'm the worlds biggest pessimist and have back-ups of all FSX related files; cfg's, ini's, exe's, aircraft, scenery, etc, etc.


Now I simply have to grind through the re-install, test, re-install, test....... You get the picture - see y'all in a week.


Oh! Forgot to mention: I'm not the originator of this thread and I don't think I can remove the "Help Please" tag. Maybe one of the admins can. Appears to me that this thread is FYI now and no longer needs the Help Me tag.

  • Like 1
Link to post
Share on other sites

Wow March I feel your pain...we all must have had similar experiances at some stage.

Last year my discs for an old copy of fsx went stupid...RC Simulations had a boat load of original fsx...probably no good to you though...

Push on through man...glad you positive about it....

I have an external hdd with all my addons etc saved....

Link to post
Share on other sites

I had similar issues with my Acceleration Pack CD when I installed on a new computer late last year.


My solution was to copy the whole content of the disk to a USB-stick and install from there. Worked like a charm.

Link to post
Share on other sites

Thanks everyone.


Issue solved using Mikael's method.


I will run CCleaner on the remnants. However, what I now have is a brand-new Win7 install on the SSD. That should take care of the registry.


What I learned:


1. Download an ISO image of Win7 from Microbust - evidently (I did not try this) it will install using your Win7 Registration Key and has all updates included. Using the old disc - amazing what we call "old" these days - I had to do 268 updates, and counting.


2. I'm going back to a tower case so I can install a RAID system. I used to use this years ago when umpteen mega $ in CAD files lived on my HDD's and a disc crash would have been disastrous.


3. Some drivers on the old C: drive, now the E: drive were saved in the Win7 sub-directories. I'm not using these sub-directories now and a few of the items on the computer are MIA. Specifically 2 of the 4 USB3 ports, and the Ethernet Hub. These are reported in the Device Manager (yellow exclamation marks) as not having drivers installed and Windoze can't find them on line. I'm going to have to contact the mobo manufacturer to see about new drivers. The Intel Website has a handy tool that is supposed to update your drivers. Unfortunately, the internet is scattered with comments and cries of anguish because the handy tool does not work.


Re-installing FSUIPC this morning to get my controls up and running.

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...