Jump to content

Recommended Posts

Hello all,


I have had problem for 3 weeks I would say. I purchased FSX steam edition about 1 month and half ago. I liked the sim and decided to purchase the airbus x addon for FSX and P3D... A couple of days after I got the airbus aircraft I started to experience a glitch where the speed brake wouldn't retract properly. It retract than go back to this default glitch position... I thought it was strange and I tried to redownload FSX and the airbus x addon thinking it was a aerosoft glitch... I talked to the guys at aerosoft on the support forum but they didnt really know what it was. It fixed itself for 3 flights but than it came back and ever since it comes back and wont go away. It really is a strange no one knows what it is, and no one else has reported having the same issue... I found out it effects the default FSX aircraft as well. So it can't be an aerosoft problem. So it must be an FSX glitch right? I dont want to spend more money if I dont have to.. But if I switch to P3D would that fix it? I need some advice cause I spent the the money and it is really annoying. FROOGLE SIM has sent me to this site. PLEASE ANYONE! give me some advice! 


Many thanks 



Link to post
Share on other sites

Welcome to the forums, I regrettably have no Great guesses, especially as the problem appears intermittent at first, then "Stuck bugged".


This is completely out of left field, but is there any chance your "/" key is sticky? it is the default key command to deploy spoilers, and an intermittently buggy key might cause that kind of problem...like i said...completely left field guess. I'll wait to see what the Real Mutley gurus think about this weird one, but wanted to extend a welcome, as well as at least one SWAG (Scientific Wild A$$ Guess).



Link to post
Share on other sites

Could be that you have spoiler controls assigned to either a button or an axis on your controller that somehow overrides the keyboard control.


Check the controller settings for spoilers in both the button and axis section of FSX and the Saitek profile software (if you use that), and make sure there are no duplicate assignments.  If you want to just have the option of fully extending/retracting the spoilers I'd remove any assignment in the Axis tab, but if you want more precision control on how much you extend them instead remove any joystick button assigned to the spoilers.


Also, double check in the controller settings in FSX if it sees your controller as one or two units by clicking the scroll list at the top of the settings window. If you see two Saitek-units in that list make sure that you only have Spoiler settings for one of them.

Link to post
Share on other sites

Hi Gavin, and welcome to Mutley's Hangar!     :)


Intermittent faults are always a pest, since you can never be entirely sure whether you've solved them.


I wouldn't rush into P3D just yet (it's not so hugely different to FSX, in many respects), let's see whether we can sort out what's going on.


You didn't actually say what you use to control the speed brake: is it the default slash key, or are you using something else that you've programmed yourself?


My initial guess would be that you're right, it *is* something to do with the "programmed button to the controls" (what is that, incidentally?). It sounds very much as though you have something in your Saitek setup which is also mapped to the speed brake, and that is taking priority over the default key, if that's what you're using. (But more information, please, especially regarding what your "programmed button" is)!    ^_^


If you could tell us what controllers you are using, that would also help. You evidently have the X52 — are you using the Saitek software with that? Throttle quadrants? Other stuff?


But as a starting point for you, I would recommend going carefully through *all* the key mappings that are set up in FSX, looking for anything to do with the speed brake; and then do the same with your Saitek software control mappings. I suspect you'll find that your speed brake is mapped to two different things at the same time, somewhere along the line.     ;)


Best of luck — let us know how it goes!





a.k.a. brian747



[Later edit: Sorry, Micke, we must have been typing at the same time. I'll stand back and let you run with this one, then, since you got there first].      :)




Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...