Jump to content

Oculus Rift S G1000 button clarity

Recommended Posts

March back again....

After a lot of time spent researching this I'm no closer to a solution, I'm beginning to think that I'm getting old and stupid. 2020 appears to require the use of a "gamepad" - I Purchased 2020 from Steam, so that's the platform I'm using. I can get my, ancient, Saitek Pedals, Yoke and Quadrant to work (the trim wheel was a nightmare despite the fact that I do know how to prevent Windoze from turning off my USB ports). That's where it ends. 

I was very much under the impression that the new sim was going to work in VR similar to using TrackIR. I keep thinking that I should be able to "look" in the VR headset at, say; an instrument, "hold" the view as long as I'm looking at it, zoom in if needed, then have the vr display return to the default cockpit view when I move my sight line back up to the windshield.

I reloaded FSX, requiring that I haul a previous computer out of storage, to try to remind myself how the system used to work. When in the virtual cockpit, depressing the Right Mouse Button (RMB) and scrolling (I use a trackball) around allows me to look around the cockpit. When I let go of the RMB the view remains where I left it. The zoom function is operable by scrolling the mouse wheel in and out. I have a button on my joystick (or the Saitek wheel/quadrant) programmed to take me back to the cockpit default pilot's position view.

This does not seem to be achievable in MSFS2020. I've tried the "Legacy" setting and a lot of other messing about in the 2020 "Controls" menus and just cannot seem to stop the 2020 mouse-driven activity that drives me to distraction: I cannot seem to scroll around the cockpit. the visual moves around but reverts to "straight ahead" almost immediately. If I'm not really careful, clicking on the mouse button(s) crashes the VR.

In fact, I'm having fun with the old FSX system and I'm contemplating dumping 2020 completely and re installing P3D and FSX.

Anyone offer some advice?

Edited by Quickmarch
Link to post
Share on other sites

Thanks for trying, Joe.

That did not do the job - there's obviously a bunch of other stuff that needs tweaking. There was some improvement in that if I use the mouse scroll wheel to click, I get some functionality but still not up to the level of FSX. That feature is not even shown in the menus, so I'm not sure what is going on.

Time to return everything to default and start over. Also time for more research.

Note that the specs at the bottom of this page are all in error as I've got #1 computer at the shop getting repairs to the Mother board. The GPU and CPU specs are lower than stated here - 1070 Card, i7 Chip, less memory, etc. I'm expecting the other computer back in a couple weeks.


Edited by Quickmarch
Specs need correcting
  • Like 1
Link to post
Share on other sites

New on this subject:

The problem seems to be the use of "Legacy" mode /General Options/Accessibility/User Interface. Turning that "off" enables the other switches/choices to (sort of) work.

I say "sort of" because I'm still trying to track down how to get the mouse wheel to zoom in and out as well as a few other things.

I'll post more on this subject as I learn. 

  • Like 1
  • Thanks 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...