Jump to content

FSX does not get past the splash screen?


Recommended Posts

Hi Guys,

Today I had a surprise through the post.

A replacement TH2G0 unit.

As you can read in the hardware forum, mine failed after 3 months.

 

Anyhow, since I've plugged everything back together, FSX does not boot any further than the splash screen.

Once it starts to boot, it says ' a problem caused fsx to stop working, Microsoft will let you know when there is a fix'.

Like MS is going to get back to me. Yeah right!

 

Any ideas guys?

 

I have tried booting FSX with just 1 screen instead of 3 but no joy.

 

Not too bothered at the moment because I cant sit at my flight pc for more than a few minutes but, I would like to find the cause without a complete re-install.

I am definitely not looking forward to that.

 

Cheers guys, any thoughts you may have or pointers to any solutions would be greatly appreciated.

 

Thanks. :(

Link to post
Share on other sites

Where do we start?

Any error codes Brian? what about the Windoze event viewer, are there any logged faults?

What have you installed since last using FSX, installed any Windoze updates? 

Try a restore to a previous time. 

Joe

 

Link to post
Share on other sites

This happened to me and it was caused by a corrupt logbook file. Try deleting the file:- X:\Users\username\Documents\Flight Simulator X Files/Logbook.bin. This worked for me and saves an install. Hope this helps.  :thum:

 

Link to post
Share on other sites

Hi Joe, Adrian & Dai,

Thanks for responding, much appreciated.

 

@Joe, There are no error codes as the error starts just as it goes from the splash screen to start the initialization process. All I get is a small window stating, Microsoft Flight Simulator has stopped working. A problem caused the program to stop working correctly, windows will close the program and notify you if there is a solution. 

When I close the box, FSX disappears.

It's that long since I used my flight pc, so I can't remember what I installed when or where. Sorry.

 

@ Adrian, Thanks for the idea, but having deleted the Logbook.bin, I have the same problem.

 

@Dai, That Dark Matter has addled your nut I fear.

 

It's beginning to look like a complete re-install. Arrrrgh! I'm thoroughly pi**ed off now. :gaah:

Link to post
Share on other sites

Sorry to hear about your FSX problem Brian. :(  The only things I could find doing research were incomplete forum posts that never really got to the root of what was going on. Some mentioned a bad sound driver or sound file (fssound.ddl) but just removing it might interfere with some aircraft that use it. You could try backing it up and deleting it then do a FSX repair but that would only be a guess on my part. Good luck and best wishes(I hate it when a program kicks a man when he's already down :D). 

Link to post
Share on other sites

Cheers Guys,

Much appreciate your thoughts.

I have tried repairing FSX but no joy as yet.

One thing I have is time, so it's still looking like a re-install.

Ah well, happy days. :D

I'm not the first, nor will I be the last.

Just don't know where the problem lies which is frustrating as you never know what to avoid in future.

Cheers :thum:

Link to post
Share on other sites

Hi Neddles

 

Have you tryed deleting you fsx.cfg file ?

 

MAKE A BACKUP BEFORE DOING SO :thum:

 

It might just turn out that the config entries in the one u have now cant find the info

 

in your reg.db after you got new hardware, so i would give that a try before going haiwire.

 

File can be found here :

 

C:\users\(yourname)\Appdata\roaming\microsoft\fsx

 

On next start it will rebulid that file, but IF NOT mabye we can disturb the thang enough

 

to at least produce an error code to work out from.

 

My 10c

 

All the best

 

 

 

Link to post
Share on other sites

Hi Viking,

Yeah, done that several times without success.

I have ordered a new case (Coolermaster HAF XB) to build a new flight sim pc, so I'm going to do a complete re-install.

I'm sick of going around in circles, doing the same tasks, to try to solve the problem.

Thanks for your thoughts though, they are much appreciated.

Cheers :thum:

Link to post
Share on other sites

You just can't catch a break can you Brian :(

 

I once had a similar problem, and if I remember correctly reinstalling FSUIPC solved it for me...

 

Could at least be worth a try..

 

Other than that, all other suggestions I could think of are already covered by others...

Link to post
Share on other sites

Cheers Guys.

I have resigned myself to waiting for the new case. :thumbup:

I will then do a reinstall and everything will be hunky dory. <_<

But with me, you'd better not take that as absolute. :D

 

@Brett, Me? Wave a white flag?? Never!!

I would rather stick hot pins in my eyes. :heat:

Or perhaps just not admit to the white flag. ;)

Link to post
Share on other sites

I had this a few years ago but i am dammed if i can remember how i fixed it at the moment. However i think i got some help from a thread on avsin. If my ancient brain responds I will get back to you.

Link to post
Share on other sites

Thanks Nigel. My grey cells are also proving ellusive at the moment.

I have, however been forced into a tight corner and have settled for a complete re-install.

Not only has FSX given up the ghost on me, my SSD with my OS on it decided to reach for the heavens and desert me today.

Why is everything going tits up this week for me?

So, fortunately for me, I had a spare 120Gb SSD (different brand), knocking about, so I am now sat installing my OS, Drivers, TH2Go, Favourites, etc etc.

It's going to be a long night. On a positive note, I can't seem to sleep at night until the early hours, so IO can sit and get on with things.

Happy daze. :stars:  (Intentional spelling error).

Wish me luck. :thum:

Link to post
Share on other sites

Hi Guys,

Update.......

I installed the spare ssd and all is well with the world. It is a Corsair Fforce 3 120Gb, so let's hope that's my run of the jitters over with for now.

@ Joe, it was indeed an OCZ Agility 3. There had been odd jitters, in the weeks prior to me being too I'll to use my flight pc, so that may have been the problem eh?

So yeah, yours has got a partner.

I'm not sure how long I've had it though, so I'll be trawling through my hardware receipts, which I tend to hoard, to see if it is still under warranty or name.

So, I have windows 7 x64 installed. Today I will be plugging in the other hdds I have, to see what software will run under the fresh install.

I'm not holding out much hope, so I'm getting mentally prepared for the upset.

I do so love a reformat, don't you? :)

Thanks guys for your comments, they are as usual, much appreciated and uplifting.

Ta ta for now and bid me well today in my quest to master the intricacies that are, the world of pc hardware. ;)

Cheers

Link to post
Share on other sites

You'll do OK Brian.

Sorry it was the OCZ but you had been having the same symptoms as me, what, about 6 months ago, so I am not surprised it went TU. No consolation I know, but my Corsair SSD has been brilliant so far.

Keep the faith, you'll do a grand job I am sure.

 

I think my CPU is on the way out now, the multiplier keeps dropping from 24 to 12, it's not overclocked so not sure why it is so unstable but it means my clock speed plummets to 1.6 Ghz and programs stutter.

 

Looking now for a new mobo/cpu combination so we are in a similar boat matey.

Link to post
Share on other sites

Lot's of luck on your quest Brian. :thum:

 

The quest for peace begins in the home, in the school and in the workplace.-Silvia Cartwright

 

The quest for peace begins in the home, in the school, in the workplace and getting FSX to work properly.-Brett Cody :D

 

 

 

 

Link to post
Share on other sites

Thanks Joe n Brett.

I certainly hope that once I have sorted these problems out, that should be it for some time.

I feel for Joe cos you have got a pretty decent CPU, so for that to be going is a nightmare.

Take Lisa out for a slap up dinner. That should work in your favour for a new CPU/mobo combo surely.

As for for your quest for peace Brett, you shoul find it pretty easy, compared to getting fsx to run smooth.

Good luck to both of you my friends.

:D

Link to post
Share on other sites
  • 2 weeks later...

can you adam and eve it? I have this now, well sort of, i have noticed over the last few days while testing fs global weather that my computer didnt want to shut down quickly, much grinding of hard drive and also it was a bit ttrady to boot up, didnt think too much about it but last night i noticed whilst it was just idling in windows that the HD seemed to be thrashing quite a lot. using 3-4% of cpu not the usual 1-2% went through the usual manoevres of cleaning out the temp files but there was no great change after a reboot, fired up fsx and boy did it take ages of hd thrashing before the free flight page came up it seemed that frozen on the splash page, but eventually it went through. the sim seemed to work normally but it took ages to load scenery etc waiting for the bar to go across , so i obviously have a problem!

there are no active applications running so thought i would try to remove some of the windows components--------- I cant get into windows update it just hangs!

It is starting to look like a reload again, well the weathers crap so it will give me something to do!

 

 

Found It!!!

 

after much , and i do mean much , hassell i found a malware called  zoomex

what a cow son to get rid of !!  required much work in safe mode with networking and severall runs through the registry before getting rid of it all

Fingers crossed

Link to post
Share on other sites

Hi BF,

I didn't want to go through the registry route as I am having probs thinking clearly at the moment but, I too started having problems after installing the - free to try - fs global weather.

After uninstalling it, no probs.

I didn't want to say anything as I wasn't wholly sure if it was the software or not.

I eventually did a complete reinstall of my OS and flight stuff.

System seems fine at the moment but we'll see how it goes once I start to install all the flight software I have.

I'm going to install one by one to see if anything untoward happens.

Thanks for your observations though.

I won't know if I had the zoomex sod on mine now, but no worries....for the moment.

Cheers :thum:

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...