Jump to content

Saitek driver load issue.


Recommended Posts

My neighbour is an FS enthusiast like me.  I sometime help him out with PC issues, but last night I came across an issue with Saitek drivers that had me stumped.  This is it:

 

His Saitek software, drivers and programming software had become corrupted. Access the programming software and the programming window would open but not show anything in it. effectively it was a blank frame of sorts.

 

When I tried to un-install the Saitek software, looked for an uninstall program but there was none, so I attempted to uninstall from the control panel.  There were two distinct programs in the control panel, one of which un-installed correctly, and the other did not. stating that a file was locked by another process.

 

The next thing I attempted was a re-install over the current one. This failed when a the install program detected an existing install.  It asked if i wanted to uninstall the old version.  I clicked yes and then yes/all to a message asking it I wanted to over write the previously installed files.  This time another error with a different message appeared along the lines of: unable to access C:\Program.

 

Naturally there was no "c:\ program" directory, only the usual pair of windows 7 program files directories. so an overwrite was no good. So I tried a manual uninstall and discovered that the locked file was the setup.exe file in the temp directory.  So I deleted the contents of the temp directory, first killing the setup process.  A re-install hit the same issue, and was still detecting a previous install.

 

Next I went through exactly the same process but this time looked at Registry entries for Saitek. I found some under the local machine entry set and removed them, there were no others. A re-install still detected an old version and failed in the way mentioned above. and replaced the files and registry entries I had removed as well as the all of the files. I was at a loss what to do next and as it was late I went home.

 

So to be clear: no matter what I did a control panel un-install error happened with the non-existent directory as the reason and a re-install error occurred with a file lock error. An attempt at a fresh install always became an uninstall as the process always detected an old version.

 

Can anyone help with a solution.  A full manual install might help or a way of repairing the un-install process.

 

Thanks JG 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...