Jump to content

FSX crash when loading flight


Recommended Posts

So after to talking to you guys I did a flight in the airbus and everything was fine. 

 

Today I downloaded ENB SERIES linked from cedarjet youtubes chanel. Fsx loaded up fine the when I clicked fly now: the loading doesnt even start it just crashes...

 

I uninstalled ENB.. and looked through my FSX root folder and found 10 crash files...

 

FSX_62615_crash....mdmp etc..

 

Any ideas?

 

Gavin

Link to post
Share on other sites

Nope it doesn't work still. I uninstalled ENB. It still crashes once I click fly now it just goes black and the white loading box never starts loading after 4 seconds it crashes. Should I re-install FSX. One guy to me to delete the logbook.bin in my FSX folder. ( cant find that )

 

gAVIN

Link to post
Share on other sites

1. EXE:

 

<?xml version="1.0" encoding="WINDOWS-1252"?>

-<SimBase.Document version="1,0" Type="Launch">

<Descr>Launch</Descr>

<Filename>EXE.xml</Filename>

<Disabled>False</Disabled>

<Launch.ManualLoad>True</Launch.ManualLoad>

-<Launch.Addon>

<Disabled>False</Disabled>

<ManualLoad>False</ManualLoad>

<Name>Addon Application</Name>

<Path>C:\MyPath\Addon.exe</Path>

<CommandLine/>

<NewConsole>True</NewConsole>

</Launch.Addon>

</SimBase.Document>

 

( 1. is from FSX/SDK/ Core utilities kit/sim connect SDK/ config/

 

2. EXE:

 

<?xml version="1.0" encoding="WINDOWS-1252"?>

 

 

Fsx/ config data/ App data/

 

DLL.

 

<?xml version="1.0" encoding="WINDOWS-1252"?>

-<SimBase.Document version="1,0" Type="Launch">

<Descr>Launch</Descr>

<Filename>dll.xml</Filename>

<Disabled>False</Disabled>

<Launch.ManualLoad>False</Launch.ManualLoad>

-<Launch.Addon>

<Name>Visual Effects Tool</Name>

<Disabled>False</Disabled>

<ManualLoad>False</ManualLoad>

<Path>..\Microsoft Flight Simulator X SDK\SDK\Environment Kit\Special Effects SDK\visualfxtool.dll</Path>

</Launch.Addon>

</SimBase.Document>

 

2.<?xml version="1.0" encoding="WINDOWS-1252"?>

-<SimBase.Document version="1,0" Type="Launch">

<Descr>Launch</Descr>

<Filename>dll.xml</Filename>

<Disabled>False</Disabled>

<Launch.ManualLoad>False</Launch.ManualLoad>


-<Launch.Addon>

<Name>Object Placement Tool</Name>

<Disabled>True</Disabled>

<ManualLoad>False</ManualLoad>

<Path>..\Microsoft Flight Simulator X SDK\SDK\Mission Creation Kit\object_placement.dll</Path>

</Launch.Addon>


-<Launch.Addon>

<Name>Traffic Toolbox</Name>

<Disabled>True</Disabled>

<ManualLoad>False</ManualLoad>

<Path>..\Microsoft Flight Simulator X SDK\SDK\Environment Kit\Traffic Toolbox SDK\traffictoolbox.dll</Path>

</Launch.Addon>


-<Launch.Addon>

<Name>Visual Effects Tool</Name>

<Disabled>True</Disabled>

<ManualLoad>False</ManualLoad>

<Path>..\Microsoft Flight Simulator X SDK\SDK\Environment Kit\Special Effects SDK\visualfxtool.dll</Path>

</Launch.Addon>

</SimBase.Document

 

 

Does that mean anything to you?

 

Cause If I re-intall FSX SE that should fix the issue.. But I will have to re-intsall all the Addons.

 

Any Ideas?

 

 

  • Like 1
Link to post
Share on other sites

I don't think those will tell us anything Gavin.

 

The versions of dll.xml and exe.xml we need to look at are located in your user profile. Look in this folder.

 

C:\Users\YOUR USERNAME\AppData\Roaming\Microsoft\FSX   or possibly FSX-SE at the end.

 

Also, it could help to see if there are any error reports in the Windows Application Log connected to the crash.

 

Not 100% sure on how to get to those in Windows 8 though.. in Win 7 and Win 10 they are accessed by Right Clicking on Computer in the Explorer and clicking Manage. From there it's going to be a bit of a shot in the dark for me as I'm running a Swedish version of Windows, so I'm not up to speed on the English vocabulary. My guess is that it is Logs - Windows Logs - Applications. See the image below.

 

Event-logs.JPG

 

Step one is to navigate to the appropriate log using the tool structure to the left, use the icons as a guide since this one is in swedish. I'm pretty sure the order is the same on an Windows installation using the English Language Pack.

 

Once the log file for Applications is loaded scroll through the list for any posts with a red circle and the text Error in the first column, or check for "Application Error" in the Source column. In the first row of text in the description you'll find the application that was the source of the error, and if you are lucky there will also be a reference to a .dll-file associated with the crash.

 

 

  • Like 1
Link to post
Share on other sites

Good to know Chris!

 

And I should possibly also have added that the "AppData"-folder is hidden by default, so to be able to see that you will need to set windows to show hidden folders and files.

 

Could anyone with an English installation of Windows possibly help with how to enable that in case Gavin needs it!

  • Like 1
Link to post
Share on other sites

Ahaha You guys are probably laughing very hard and righlty so!

 

<?xml version="1.0" encoding="WINDOWS-1252"?>

-<SimBase.Document version="1,0" Type="Launch">

<Descr>Launch</Descr>

<Filename>dll.xml</Filename>

<Disabled>False</Disabled>

<Launch.ManualLoad>False</Launch.ManualLoad>

-<Launch.Addon>

<Name>Addon Manager</Name>

<Disabled>False</Disabled>

<ManualLoad>False</ManualLoad>

<Path>bglmanx.dll</Path>

</Launch.Addon>

-<Launch.Addon>

<Name>Object Placement Tool</Name>

<Disabled>True</Disabled>

<ManualLoad>False</ManualLoad>

<Path>..\Microsoft Flight Simulator X SDK\SDK\Mission Creation Kit\object_placement.dll</Path>

</Launch.Addon>

-<Launch.Addon>

<Name>Traffic Toolbox</Name>

<Disabled>True</Disabled>

<ManualLoad>False</ManualLoad>

<Path>..\Microsoft Flight Simulator X SDK\SDK\Environment Kit\Traffic Toolbox SDK\traffictoolbox.dll</Path>

</Launch.Addon>

-<Launch.Addon>

<Name>Visual Effects Tool</Name>

<Disabled>True</Disabled>

<ManualLoad>False</ManualLoad>

<Path>..\Microsoft Flight Simulator X SDK\SDK\Environment Kit\Special Effects SDK\visualfxtool.dll</Path>

</Launch.Addon>

-<Launch.Addon>

<Name>VistaMare Core</Name>

<Disabled>False</Disabled>

<ManualLoad>False</ManualLoad>

<Path>VistaMare\ViMaCoreX.dll</Path>

</Launch.Addon>

-<Launch.Addon>

<Name>FS Recorder</Name>

<Disabled>False</Disabled>

<ManualLoad>False</ManualLoad>

<Path>C:\Program Files (x86)\FS Recorder for FSX\FSRecorder_FSX.dll</Path>

</Launch.Addon>

-<Launch.Addon>

<Name>RAASPRO</Name>

<Disabled>False</Disabled>

<ManualLoad>False</ManualLoad>

<Path>.\RAASPRO\RAASPRO.dll</Path>

<DllStartName>module_init</DllStartName>

<DllStopName>module_deinit</DllStopName>

</Launch.Addon>

-<Launch.Addon>

<Name>FSUIPC 4</Name>

<Disabled>False</Disabled>

<Path>Modules\FSUIPC4.dll</Path>

</Launch.Addon>

</SimBase.Document>

 

This DLL. xml document is in my APPDATA FSX SE folder.

 

 

 

<?xml version="1.0" encoding="WINDOWS-1252"?>

-<SimBase.Document version="1,0" Type="Launch">

<Descr>Launch</Descr>

<Filename>EXE.xml</Filename>

<Disabled>False</Disabled>

<Launch.ManualLoad>False</Launch.ManualLoad>

-<Launch.Addon>

<Name>Couatl</Name>

<Disabled>False</Disabled>

<ManualLoad>False</ManualLoad>

<Path>fsdreamteam\couatl\couatl.exe</Path>

</Launch.Addon>

-<Launch.Addon>

<Disabled>True</Disabled>

<ManualLoad>False</ManualLoad>

<Name>Addon Application</Name>

<Path>C:\MyPath\Addon.exe</Path>

<CommandLine/>

<NewConsole>True</NewConsole>

</Launch.Addon>

-<Launch.Addon>

<Name>EZdok camera addon</Name>

<Disabled>False</Disabled>

<Path>C:\Program Files (x86)\EZCA\EZCA.exe</Path>

</Launch.Addon>

</SimBase.Document>

 

Thats my addon launch that wont help....

 

Faulting application name: EZCA.exe, version: 1.1.8.6, time stamp: 0x2a425e19
Faulting module name: unknown, version: 0.0.0.0, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0xff080000
Faulting process id: 0xf44
Faulting application start time: 0x01d14358cec93884
Faulting application path: C:\Program Files (x86)\EZCA\EZCA.exe
Faulting module path: unknown
Report Id: 1429a4bc-af4c-11e5-8318-f0795965aac0
Faulting package full name:

 

EZDOK cant be the issue cause even when I disable ezdok it still crashes

 

Is this what you want?

 

Gavin

 

 

  • Like 1
Link to post
Share on other sites

we're loughing with you ;)

here's your EXE.XML code, replace your old with this

<?xml version="1.0" encoding="WINDOWS-1252"?>
<SimBase.Document version="1,0" Type="Launch">
<Descr>Launch</Descr>
<Filename>EXE.xml</Filename>
<Disabled>False</Disabled>
<Launch.ManualLoad>False</Launch.ManualLoad>
<Launch.Addon>
<Name>Couatl</Name>
<Disabled>False</Disabled>
<ManualLoad>False</ManualLoad>
<Path>fsdreamteam\couatl\couatl.exe</Path>
</Launch.Addon>
<Launch.Addon>
<Disabled>True</Disabled>
<ManualLoad>False</ManualLoad>
<Name>Addon Application</Name>
<Path>C:\MyPath\Addon.exe</Path>
<CommandLine/>
<NewConsole>True</NewConsole>
</Launch.Addon>
</SimBase.Document>

to compare; below is your old EXE.XML,
i stripped out "EZdok camera addon" entry

<?xml version="1.0" encoding="WINDOWS-1252"?>
<SimBase.Document version="1,0" Type="Launch">
<Descr>Launch</Descr>
<Filename>EXE.xml</Filename>
<Disabled>False</Disabled>
<Launch.ManualLoad>False</Launch.ManualLoad>
<Launch.Addon>
<Name>Couatl</Name>
<Disabled>False</Disabled>
<ManualLoad>False</ManualLoad>
<Path>fsdreamteam\couatl\couatl.exe</Path>
</Launch.Addon>
<Launch.Addon>
<Disabled>True</Disabled>
<ManualLoad>False</ManualLoad>
<Name>Addon Application</Name>
<Path>C:\MyPath\Addon.exe</Path>
<CommandLine/>
<NewConsole>True</NewConsole>
</Launch.Addon>
<Launch.Addon>
<Name>EZdok camera addon</Name>
<Disabled>False</Disabled>
<Path>C:\Program Files (x86)\EZCA\EZCA.exe</Path>
</Launch.Addon>
</SimBase.Document>
Link to post
Share on other sites

Since there is a mention of EZCA.exe in your log-files that's a good place to start, although I think Chris had a slight brain fart.. Just replace every mention of DLL.xml in his last post with EXE.xml  ;)

 

Also remember to make a backup of your original exe.xml before you start to have something to roll back on in case of failure...

 

Also, do you know what this bit in the EXE.xml is referring to?

<Launch.Addon>
<Disabled>True</Disabled>
<ManualLoad>False</ManualLoad>
<Name>Addon Application</Name>
<Path>C:\MyPath\Addon.exe</Path>
<CommandLine/>
<NewConsole>True</NewConsole>
</Launch.Addon>

Never seen that one before.

  • Like 1
Link to post
Share on other sites

I think Chris had a slight brain fart..

 

Oops... :th_blush:

two tiny mistakes in the description above the code fixed; the code snippet itself was/is fine :whis: ,

i wondering about that strange entry too; since its disabled it’s not likely to effecting this condition,

Link to post
Share on other sites

 

I think Chris had a slight brain fart..

 

Oops... :th_blush:

two tiny mistakes in the description above the code fixed; the code snippet itself was/is fine :whis: ,

i wondering about that strange entry too; since its disabled it’s not likely to effecting this condition,

 

 

Ahh.. missed that the Disabled tag was set to TRUE  ;)

  • Like 1
Link to post
Share on other sites

What this going to do? 

 

Is this:

 

<?xml version="1.0" encoding="WINDOWS-1252"?>
<SimBase.Document version="1,0" Type="Launch">
<Descr>Launch</Descr>
<Filename>EXE.xml</Filename>
<Disabled>False</Disabled>
<Launch.ManualLoad>False</Launch.ManualLoad>
<Launch.Addon>
<Name>Couatl</Name>
<Disabled>False</Disabled>
<ManualLoad>False</ManualLoad>
<Path>fsdreamteam\couatl\couatl.exe</Path>
</Launch.Addon>
<Launch.Addon>
<Disabled>True</Disabled>
<ManualLoad>False</ManualLoad>
<Name>Addon Application</Name>
<Path>C:\MyPath\Addon.exe</Path>
<CommandLine/>
<NewConsole>True</NewConsole>
</Launch.Addon>
</SimBase.Document>

 

I put this in my EXE.XML or DLL.XML.

 

I will try this ( if its right ) But lets say I decide to re-install FSX SE tmr, and that doesnt work does that mean my drivers need to be updated cause last time I checked ( not long ago ) they where fine.

But if the re-installation doesnt work what could I do. I just want to know my options in that case. I would un-install before re-installing FSX SE through steam obviously and then check to see if it still crashes when I click FLY NOW". If it works I will install my addons and make sure its a clean installation. I hope to get flying for the weekend, If its not fixed by then I dont know what to do.

 

Thanks- gavin

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...