Jump to content
johan

Saitek Proflight Throttle Quadrant Problem

Recommended Posts

HI folks,

 

My Saitek Proflight Throttle Quadrant works perfectly using the "mouse", however when I use the actual Saitek Proflight Throttle Quadrant 'handle' itself, it jumps from "idle" to full throttle eg. 2300rpm in one move so NO gradual movement in rpm at all.

The Throttle Quadrant has been connected to Saitek Pro Flight Yoke - SP2. ( Also connecting straight into PC makes no difference either).

Hopefully someone can help me with this strange problem?

Regards,

Johan

 

 

Share this post


Link to post
Share on other sites

Hi Johan, there's been a lot written about this on the internet as no doubt you have seen.

There doesn't seem to be a cure all solution but in my experience when the potentiometer gets dust or dirt inside they can go spiky. These items are not really serviceable other than using some switch cleaner to lubricate the contacts. Have a look on YouTube.   

  • Thanks 1

Share this post


Link to post
Share on other sites

Thanks Joe ,  sorry but the question is wrongly (set up).      

eg: Cessna C72 SP Flight Sim X  :controll panel: moving the trottle bij mouse - curser,

                                                        works perfect.

using the Saitek Proflight Trottle Quadrant     left handle -O- Engine-800 rpm

                                                                                     moving - 20- jump -2300 rpm

                                                                                          "  50-75-100-no action-2300 rpm

             the trottle connected to Saitek Proflight Yoke-SP2, 

                                                   straight into comp- no differance

 

 

                                             

 

Share this post


Link to post
Share on other sites
Quote

My Saitek Proflight Throttle Quadrant works perfectly using the "mouse", however when I use the actual Saitek Proflight Throttle Quadrant 'handle' itself, it jumps from "idle" to full throttle eg. 2300rpm in one move so NO gradual movement in rpm at all.

The Throttle Quadrant has been connected to Saitek Pro Flight Yoke - SP2. ( Also connecting straight into PC makes no difference either).

So let's get this clear. Using mouse and the 3D cockpit works fine.  Using the Saitek throttle is the issue. You have the Saitek throttle plugged into the yoke but it also dosent work if you plug it into its own USB port.

Have I got this correct?

What software are you using with the throttle? Saiteks own or FSUIPC?

If the above is correct it would seem likely to be a software set-up issue.  Dirt in the throttle can be an issue but it usually manifests itself with a jittery throttle and not an all or nothing issue which, if I have it correct, seems to be the case here.

Try recalibrating the throttle unit and see where that gets you first.

If you are using Saiteks own software then install FSUIPC and use that, don't forget to disable the saitek software first. - Which raises the point..... if you already have both the Saitek software and FSUIPC loaded then look for a conflict between the two.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...