Jump to content

Recommended Posts

Just added Hawker 800XP and for some reason when flying for a short period it starts to judder then it will go back to flying smoothly, not sure whats causing the problem. I'm using a AMD FX-6100 Six-Core Processor (6 CPUs), ~3.3GHz, Geforce GT 640 with 4Mb and 16 Mb ram. Any-one have any idea whats causing the juddering.

 

jm :huh:

Link to post
Share on other sites

I have had this once or twice in the past, and found out that the p.c. was running another process behind fsx. and that was using either cpu time or memory sometimes it is the antivirus doing a check up  or something like that when it happens next time fire up the task manager and see what is running

I generally wait a few minutes after firing up fsx and the p.c. so that these things stop running, if you wait for fsx to finish loading listen to your hard drive or look at the access light they should all be quiet if they are not you know something else is going on.

Link to post
Share on other sites

Well regarding the programs running in the background, that is a good possibility, I will check next time Ioad FSX. With the anti-virus, I only schedule on start-up and once a week for the full system check that said I suppose it will still run in the background, as it is supposed to do. What I have done since posting my original post is to re-install FSX & Accelerator, then install each of my planes separately whilst checking my flight over the same area and height after each install, the only thing I have not done is re-install Ultimate Traffic 2, so far everything is running okay.

 

Thanks for the advise

 

Link to post
Share on other sites
  • 2 weeks later...

There is one thing else to consider here, and you may have accidentally fixed it by re-installing FSX.

 

It could be that your hard drive (HDD) needs defragging. When you install a program on to a HDD it will fit it into spaces where it can. If you have a nearly full HDD then it will install the files into any space it can find, then index them so it knows where the relevant data is.

 

Now a hard disk has an arm that moves across the disk to where the data it wants is to read it. If that data is in small bits tucked away hither and thither, the arm has to do a lot of tracking back and forth collecting the relevant data.  This all takes time, and it may be that the stuttering is caused by delays in retrieving date because of the above. If you delete data from your HDD than this has no effect on this problem as it wont move the data that remains.

 

However if you defrag your HDD then it will move the data around on your disk so that the seek time is minimized and data retrieval time is much faster. 

 

So if you installed FSX programs on a nearly full HDD and then made some space, then you do a complete re install the chances are that you re installed the data in a more efficient way and solved your problem.

 

NOTE. If you have a solid state HDD there are no seek times as there is no mechanical mechanism retrieving data (that is why they are so much faster).  This being the case, you should NOT defrag your HDD.

Link to post
Share on other sites

There is one thing else to consider here, and you may have accidentally fixed it by re-installing FSX.

 

It could be that your hard drive (HDD) needs defragging. When you install a program on to a HDD it will fit it into spaces where it can. If you have a nearly full HDD then it will install the files into any space it can find, then index them so it knows where the relevant data is.

 

Now a hard disk has an arm that moves across the disk to where the data it wants is to read it. If that data is in small bits tucked away hither and thither, the arm has to do a lot of tracking back and forth collecting the relevant data.  This all takes time, and it may be that the stuttering is caused by delays in retrieving date because of the above. If you delete data from your HDD than this has no effect on this problem as it wont move the data that remains.

 

However if you defrag your HDD then it will move the data around on your disk so that the seek time is minimized and data retrieval time is much faster. 

 

So if you installed FSX programs on a nearly full HDD and then made some space, then you do a complete re install the chances are that you re installed the data in a more efficient way and solved your problem.

 

NOTE. If you have a solid state HDD there are no seek times as there is no mechanical mechanism retrieving data (that is why they are so much faster).  This being the case, you should NOT defrag your HDD.

Hi Captain,

thank you for the info but two things inmy favour, firstly my HDD is a new 2TB, secondly I do defrag both my drives on a regular basis. So I'm sure that might not be the problem. but since sorting the issue out unfortuneately it has reappeared, I use a test flight to check flight sif I have made any changes to the fsx.cfg file, which I had, trying to get the bestoptions out of my system. Following some notes given by avsim I tweaked my system using some (not all) of the suggestions. The only effect I had was more of teh juddering, this did not matter which plane I used, after deleting the cgf file I pasted the original back with no effect. So after  a few cups of tea I switched off with the intension to do yet another install, do get me wrong I'm no expert in tweaking things but the systemI'm running ( although not as good as some) is good enough to give me a good steady display.

Link to post
Share on other sites

It looks like a pretty good system you have although I'm no expert. Some folks think they can max out all their settings. Have you tried backing off some of your settings to see if one of them is causing to much of a memory draw. Only guessing here because you have not mentioned how your settings are set up. You can also play around with the custom section of your graphics card to see what setting might smooth things out. Remember to take notes of what you are changing so you can keep track and change things back.

 

There are so many things that can cause the studders that in-depth testing might be your only answer.

 

Have you tried Kostas guide? I suggest reading through it first to get an overall understanding of what he is trying to do.

Link to post
Share on other sites

It looks like a pretty good system you have although I'm no expert. Some folks think they can max out all their settings. Have you tried backing off some of your settings to see if one of them is causing to much of a memory draw. Only guessing here because you have not mentioned how your settings are set up. You can also play around with the custom section of your graphics card to see what setting might smooth things out. Remember to take notes of what you are changing so you can keep track and change things back.

 

There are so many things that can cause the studders that in-depth testing might be your only answer.

 

Have you tried Kostas guide? I suggest reading through it first to get an overall understanding of what he is trying to do.

Hi Brett,

The settings within fsx.cfg I have set these using some of the advised settings by avsim hardware guide but not all, and in FSX custom settings the settings are not as high as the would have been had I let FSX set them to the default settings, this is what is puzzling me. I will be doing a repair  later then I plan to rip out all the aircraft files apart from the C172, I'll fly that on my test route and see what happens, depending on the results I'll re-install the standard aircraft file and try again. Theni'll add each addon seperately test each time hopefully I might find out what is causing this issue.

 

Thank for the suggestions.

<_<

Link to post
Share on other sites

I highly recommend not deleting any default aircraft.

Hi Brett,

well I didn't delete the default aircraft, so instead I did (another) FSX install,then Accelerator finally Ultimate Terrain Europe 2. With each install I did a test flt using the same conditions and fly plan. Everything worked out fine until I re-installed Ultimate Terrain Europe 2, thats when my issue's began agian. But as I said before with my settings set just below what the default settings are I would have thought that the juddering would not appear but it does, so slightly confused at this point.

 

:gaah: :gaah:

Link to post
Share on other sites

I do not have UTX products so I can't really help you there. Obviously this program is causing it. You can try lowering the load radius or if UTX has 3D lighting try turning if off at least in the day time.

Link to post
Share on other sites

I think I'll pack up flying. Now getting the following message 'Your computer has run out of available memory. Please restart Flight Simulator and select different graphics, scenery or traffic settings'.

 

My settings are already below the 'Restore Default settings' I can't undertsand why this is happening, does anyone know the answer, before I chuck it into the bin.

 

Getting desperate now.

Thanks

 

:stars:

 

Link to post
Share on other sites

There are 2 add ons that I consider essential to my fsx hard drive , they are all cpu meter  and  gpu meter

They use hardly any memory but if you have an issue you can see staright away whether it is cpu or gpu that is the cause

for example when windows is running and nothing else is (theoretically) the cpu usage should be 1% or less when I had a juddering issue last year i noticed it was at 3 or 5% so i investigated , found that my antivirus was running a check in the background , stopped it and no more juddering.

they are both available from here:

http://addgadgets.com/gpu_meter/

just put them in the sidebar

Link to post
Share on other sites

There are 2 add ons that I consider essential to my fsx hard drive , they are all cpu meter  and  gpu meter

They use hardly any memory but if you have an issue you can see staright away whether it is cpu or gpu that is the cause

for example when windows is running and nothing else is (theoretically) the cpu usage should be 1% or less when I had a juddering issue last year i noticed it was at 3 or 5% so i investigated , found that my antivirus was running a check in the background , stopped it and no more juddering.

they are both available from here:

http://addgadgets.com/gpu_meter/

 

just put them in the sideThanks for the link, I'll check it out when I startup my FSX, on first viewit's running at between 0 - 1 % I'll let you know what the reading i swhen I start FSX.

 

:thum:

Link to post
Share on other sites

Since you said you had followed a few guides on AVSIM I assume you already have the HIGHMEMFIX=1 line added to the GRAPHICS section of the fsx.cfg..

 

If not, start by applying that.

Thanks, yes I have put in the 'HIGHMEMFIX=1' as it's displayed in the guide.

;)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...