Jump to content

Recommended Posts

:help:

Any FSUIPC gurus out there ??

Need your help....

 

During the various resets and trying my yoke out in different ports (following the issue with the disco lights on my yoke display), I seem to have pretty much boogahhed up my FSUIPC settings.

 

In order to test the yoke, I tried it in different USBs (major bad move) and a different PC... all to no avail, and now that everything is plugged back in where it belonged, my Saitek Cessna trim does diddly squat !

 

I don't have the Saitek Trim software (or any Saitek software for that matter) installed on my rig, and I was using a LUA command to run my trim before without any issues.

 

This is the Lua I was running:

 

function checkvalue(val)

  if prev~=nil then

     if val > prev then ipc.control(65615)

     elseif val < prev then ipc.control(65607)

     end

  end

  prev = val

end

event.param("checkvalue")

 

I had it saved as "trimwheel.lua" and then added an [auto] 1=Lua trimwheel

 

All was groovy for the last year since I got the trim wheel, and now all of a sudden, its all gone wrong.

 

I checked in the FSUIPC .INI file for the JOY numbers and my Yoke and Trim had swapped round from 1 to 0 respectively so I have manually changed them back, but no joy (no pun intended)

 

I guess my only option to make sure that it all works is to start from scratch and just 'BLANK' the entire FSUIPC INI, but I'm not sure what effect it will have on any other settings or Configs in FSX.

 

Anyone out there know how I can just wipe the FSUIPC file and start again ? 

 

Help would be appreciated.

I was pondering putting this on the Peter D website but I'm too chicken  :scare:

Minx

 

 

Link to post
Share on other sites

Hi Steph,

 

We do have a FSUIPC guru on the books but I don't want to name and shame if he is not around.

 

So, I have the trim wheel but have never calibrated it through FSUIPC, FSX has always seemed to pick it up ok.

 

Probably, the quickest/ easiest way would be to set the axes up again via FSUIPC (I assume you have the registered version?)

 

Hopefully you will get a more useful reply than this..  :)

 

Joe

Link to post
Share on other sites

Thanks for the suggestion Joe.

Just being creative in the kitchen but will give it a whirl to see if fsx will just pick it up again..

The Lua has worked so well it would be good to get it working again and although I'm not adverse to starting from scratch to get it right, if I can fly in th r meantime that's a bonus. Sometimes feels like i spend more time tweaking than flying!

Thanks again for replying so quickly :D

Link to post
Share on other sites

No Joy Joe

... the trim wheel can go for countless turns and not pick up in the controls setup page

...back to 'how do I clear all my FSUIPC settings' ??

 

I guess I could just delete everything from the FSUIPC modules and see what it tries to re-build but not sure whether that's the best idea.

 

Any insights out there with a paid FSUIPC, W7, Cessna trim and a lua ??

 

Link to post
Share on other sites

No go with this...

I had no joy with getting fsuipc to use lua which had worked perfectly in the past, so I deleted the fsuipc.ini and started from scratch in the hope it would work on something as simple as a c172 default....

....comput'a says nah!

Have tried setting the trim in fsx controls and although the little cross seems to move in calibration it wont move the wheel when im in the cockpit, regardless of how many times ive turned it.

Also tried to run the saitek driver for a laugh, set up the wheel in fsx controls and the trim seems to move a small amount, mainly nose down to nose up to about 3 degrees which is nowhere near enough, it then just freezes.

so.... guess im back to where I was a week ago with no working trim unless I go back to yoke or mfd trim, plus I now need to get some hair dye as ive now got a million new grey hairs (not a good look when your hair's as long as mine)

I've spent the last 3hours trolling the net for inspiration and it looks like my lua script should work.

Call goes out again for any keen fsuipc fanatics out there... anyone?

Link to post
Share on other sites

Hi Steph,

 

I agree your Lua script should work, I have that very same trim wheel but always set it up via FSX.

 

Presently, I don't have the wheel installed but I will have a go reinstalling it tomorrow.  From what I remember, you have to turn the wheel a few times in order for it to register, I think that's because of the nine turns it takes to get from one extreme to the other.  If you have your AP on the trim wheel will not work either.

 

I'll get back to hope hopefully someone else could chime in  :)

Link to post
Share on other sites

Hold that thought Joe...i think I might have cracked it!

Had to go back to the StandardXML, remove everything under the trim wheel and then calibrate by turning the wheel 9 full times even though it had gone past the stop in each direction. That way fsx sees the entire range of motion and not just what you see it doing in the box.

Like you say the trim wonot work with autopilot but good old fsuipc resets it to 0 when the autopilot is disengaged as part of its 'God' settings. I'm now gettinga pretty perfectly centred trim when I turn on fsx regardless of the aircraft. Woo hoo!!!

I'm prepared for the trim wheel to not work with the pmdg ngx which is one of the reasons I had to use the Lua in the first place but at least I'm back flying without spending hours cursing!! :D

Link to post
Share on other sites

Hi ,

 

I installed my trim wheel and I had to use FSUIPC to get it to work with the default KingAir.

 

However, I calibrated the trim wheel in FSX (PC) first then deleted all the FSX Axes and button assignments for it. Then fired up and set the Axis up as Joy# 0 X Axis# (Had to turn the wheel a lot!) then sent direct to FSUIPC calibration with an action of elevator trim.

 

It all worked fine, but did work directly into FS as it would also operate throttle 1 at the same time even though it wasn't assigned.

 

Flight sims eh? who'd have 'em!

 

Anywho pleased you have found an acceptable solution.

 

Cheers.

Joe

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...