Jump to content

No luck netwrking with Plan G

Recommended Posts

Hi guys

Need some advice here (probably from Joe or Needles..??)


I've been wanting to use Plan G for ages but as I use a Triple Head to go with my 3 screens (in Full screen mode) I can't run it on my 4th screen unless I network.


I brought my husbands HP machine out of 'retirement', chucked some extra memory in it, connected it to the home network via an Ethernet switch/hub, but I've had nothing but problems.. 

Every time I press the 'connect button' about 3 seconds later I get an error message 'Plan_G3 has stopped working' and it closes.

Looking at the Plan-G Log I can see that it is trying to initiate the SimConnect connection, but it says 'attempt timed out'


Both PCs are running Win7, both are connected to the Home Network and can see each other


I have tried:


  • Turning off the firewall on both
  • Turning off the antivirus on both
  • I have 'pinged' both PCs and they can see each other fine
  • Used the automatic IP address
  • Re-set the FSX computer to a Static IP address
  • Changed the Port from 4505 to 4506  (strangely the instructions state that you can only have ports between 4500 to 4510, but a check on the ports list via 'NetStat' shows ports from 41294 to 50739!!)
  • Tried setting up the SimConnect.XML as IPV6  AND IPV4  - (when I found that IPV6 wasn't working I re-wrote the SimConnect.xml to IPV4, but realised that each time I changed the details in the Location option on PlanG that it decided to keep reverting to the IPV6 settings so I had to uninstall PlanG, delete all the folders that were still on my HD, and cleared the registry... )
  • Tried all versions of the 'Templates' included in the PlanG User Manual, to no avail
  • Shouted loudly at my PC.. reckon it must be hard of hearing

At this point, I am left with the following options:

  • Accepting Pan G will never work with my set up, although the millions of happy users indicate it works when you get the settings right
  • Purchasing WideFS - no problem with this as I have the thoroughly fantastic FSUIPC and if it works, it will be a small price to pay for the 8 hours I've already spent checking through everything to eliminate the obvious
  • Hoping that the great minds on the Hanger can com up with an option I haven't thought of !

Suggestions?  Commiserations? Hammer / Baseball bat (for those across the pond from Blighty) ?


I'm going to give this till tomorrow night before I flex the MasterCard and give Mr Dowson a small token of my thanks..



Link to post
Share on other sites

Thanks John.

Will give that a go when I get up (its only 5am here but I can't sleep so I'm surfing on my mobile...)

One other thing that has been bugging me was every time I re-set the Location (the static ip address and port) Plan G promptly forgot the port number and re set it to zero. There is no OK button to press and when I click exit I had mixed results! The only thing it seems to do consistently, is to crash when I hit connect. Very strange!

The Plan G forums have a number of similar threads but nothing that exactly matches my issue which is hardly surprising when everyone's setup will be different. Some have found only the WideFS option to be the solution so I can't rule it out but would be handy to save a few coppers...

Link to post
Share on other sites

Update on Plan-G... well, not really, as I still can't get it to work.

Setting the connection to FSUIPC did stop it disconnecting and crashing, but it didn't do anything either.. just sat there till I turned it off, at which point it just crashed again.


Gonna ping this onto the PlanG site too to see if there are any silly things that I've missed.. but its looking more and more like I will have to get WideFS. More manuals [deep joy!]


Thanks for the earlier ideas, John.. I had to try everything


Link to post
Share on other sites

By jove, I think I've got it !!

Talk about jumping through hoops...

In order for it to work, and in case anyone else comes across the same problem, this is what I had to do:


  • I had to install Microsoft SDK Client onto the networked machine (the Plan G instructions actually instruct you not to but I had tried everything else so I figured I'd give it a go!). I copied the SDK.msi from my SDK folder on the FSX machine onto the networked and ran it. As I have Acceleration, there was only one SDK entry in my Programs once installed.
  • I also needed to copy across the SimConnect.ini  from my SDK folder to  Documents>Flight Simulator X Files on the main machine which looked like this:

console=0   (this was originally 1 in my SDK, but that seems to run a diagnostic tool when you start FSX, so I changed it to 0)

  • I then updated the Port number in the SimConnect.XML so that it was 5000  (I'd had no luck with numbers 4500 - 4510, and I new that I had ports on my machine which were numbered higher than that)
  • I then created a SimConnect.cfg file on the networked machine and added in the IP address of the FSX machine.



Address=  This is the IP address of the FSX machine

Port=5000 I knew from running a search on my FSX machine that I had ports in the 5000's so I just picked one




The only thing I'm expecting now is that the IP address will probably change each time I log on, but its a doddle to find it (Start menu > Control Panel . Network and Internet> Network and sharing centre> Local Area Connection > Details (on the general tab)


Well, I can't say that its been the best use of my entire weekend, but at least I have got it sorted out...


If I ever decided to add any other programs onto the other networked PC, I would definitely go for WideFS. For the £20 it currently costs to buy, it would have been money well spent (and may still be !)


Now I can delve into the great things that Plan G, together with all the files that John Allard has tirelessly worked on... I for one am chuffed to bits :D


Happy flying all



Link to post
Share on other sites
  • 3 weeks later...

I almost gave up and bought Widefs but perseverance paid off.


.... and after having to phaff about with settings again, I gave up on SimConnect and bought WideFS!

I probaby could have just saved myself all the hassle in the first place, but no... I had to carry on, doggedly trying to make it work. I don't tend to give up easily, but in the end I was burning up too much flying time.


Joe: can you change the marker on this one from 'help please' to something more fitting? Cheers

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...