Jump to content

EZDok and P3D v3.2

Recommended Posts

I am trying to install EZDok v1.18.7 into P3D v3.2


I cant get it to work!!  I keep getting the following error:


The ROOT section in EXE.XML file not found. EZCA will not start automatically


There are a few suggested fixes out there on the interwebs which involve manually adding lines to to the EXE.XML file, which I have tried and which don't work for me.


I do get some output to the install process as the  View>Change View and View>New View both have a menu item of EZCA World Cam. This menu item if clicked takes you off to a place way above the clouds far away enough to for P3D to re-draw all the scenery.


However there is no link to the EZDOK control panel.


Has anyone else had this problem?





Link to post
Share on other sites

Hi John!

I've never seen that problem myself. The only thing that occurs to me at the moment is — if the message means (as it seems to) that it can't find EXE.XML, then presumably it can only be one of two things:


a) It's looking in the wrong place. (Does P3D squirrel it away somewhere weird that EZCA a.k.a. EZDOK wouldn't know about??)




b) It's one of those dratted permissions things. (Have you tried TakeOwnership and so on?).    :mellow:


Just a suggestion — sorry I can't be of more help (but it's P3D...   aaargh!).     ;)


Good luck,



a.k.a. brian747


  • Like 1
Link to post
Share on other sites

@ Brian It could be either I supose.  Trouble is I know where the file is but I don't know where it is looking.  I dont think it is a permissions thing as my login is a windows administrator and the file is under users/john/....


Are there any P3D v3 users out there who use EZDok?  If so can you let me know the path to the EXE.XML file and its contents.





Link to post
Share on other sites

Hi, John!


It still sounds to me like a problem with your EXE.XML file. I assume you've checked the formatting of the sections in there, but have you taken a look at it in a binary editor to see whether there are any control characters or line feeds or whatever invisibly buried?


FWIW you might find something useful in this thread: http://www.avsim.com/topic/428438-ezdok-help-root-section-in-exexml-file-not-found/#entry2872798









Link to post
Share on other sites

Not so odd if you think about it.  The original error was: 


" The ROOT section in EXE.XML file not found. EZCA will not start automatically"


So I there was something wrong with the EXE.XML file.  This file controls the start up of various apps within FSX or P3D itself. So there was obviously a file corruption or a permissions issue with this file. I looked at the file and found nothing much in there, so I added the proper entries for EZDok (found on the interwebs) and saved the file.


I rebooted and started P3D and nothing had changed, no EZDok in my P3D menus. 


I know a lot of the various FSX config files are created by the system if they are not found.  P3D is not much different in this, and as the EZDok install needs this file I hopped that it would create one if none were found.  So I uninstalled EZDok and then renamed the EXE.XML file so that P3D and the EZDok installer thought it wasn't there. I then reinstalled EZDok.


After the install all was well and as I had guessed correctly about the EXE.XML creation and new and perfectly formed file was created. On starting P3D the XML file was correctly read and there was EZDok in the P3D menu as it should be.  




Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...